Ticket #6966 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Pressing ESC on dialog when 2 dialogs are open closes both dialogs

Reported by: fracmak Owned by:
Priority: minor Milestone: 1.8.16
Component: ui.dialog Version: 1.8.9
Keywords: Cc:
Blocking: Blocked by:

Description

The correct behavior is to only close the active dialog.

Change History

comment:1 Changed 3 years ago by fracmak

A pull request has been made that fixes this issue.

comment:3 Changed 3 years ago by scott.gonzalez

  • Status changed from new to open

The  new pull request can land if we can get core to fix the problem where native events don't carry properties over properly when bubbling (see pull request for details).

Last edited 3 years ago by scott.gonzalez (previous) (diff)

comment:4 Changed 3 years ago by Jay Merrifield

  • Status changed from open to closed
  • Resolution set to fixed

Dialog: Before handling escape key presses, check if the default action has been prevented. Fixes #6966 - Pressing ESC on dialog when 2 dialogs are open closes both dialogs.

Changeset: f9996682b5739661c21548f0de3d4c4883c5119d

comment:5 Changed 3 years ago by scott.gonzalez

#5365 is a duplicate of this ticket.

comment:6 Changed 3 years ago by scott.gonzalez

#3539 is a duplicate of this ticket.

comment:7 Changed 3 years ago by andreaspelme

This is not applied in the latest 1-8-stable tree. Why? It seems a pure bug fix and something that just bit me. The fix seems to be trivial to include in the 1-8-stable branch.

Here is a pull request for 1-8-stable with the patch backported:  https://github.com/jquery/jquery-ui/pull/415

comment:8 Changed 3 years ago by Andreas Pelme

Backport of f9996682b5739661c21548f0de3d4c4883c5119d for 1-8-stable.

Original commit message from f9996682b5739661c21548f0de3d4c4883c5119d: Dialog: Before handling escape key presses, check if the default action has been prevented. Fixes #6966 - Pressing ESC on dialog when 2 dialogs are open closes both dialogs.

Changeset: abf97f73017794f93c52876221cf34018da5781c

comment:9 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.16

comment:10 Changed 3 years ago by scott.gonzalez

Thanks andreaspelme. The reason it wasn't included in 1-8-stable is because it didn't merge cleanly. Because some widgets are vastly different in 1-8-stable and master, if a non-blocker bug fix doesn't merge into 1-8-stable cleanly, we simply ignore it in favor of spending time working on master to get 1.9 out the door faster. We're always willing to accept patches to fix 1-8-stable from the community in these cases, so thanks for taking the time :-)

Note: See TracTickets for help on using tickets.