Ticket #6978 (closed bug: fixed)

Opened 3 years ago

Last modified 22 months ago

In Calender for march 2011 dates showing till 5th only.

Reported by: jomyjohn Owned by:
Priority: minor Milestone: 1.8.10
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocking: Blocked by:

Description

In Calender for march 2011 dates showing till 5th only. I am using Jquery Calendar successfully in my application . But I am getting a strange problem from Jordan users. Users from there can see dates only till 5th. No rows show after that. This issue happens only for the march 2011. It works for all other months even for march 2012. I test your demo application page also. There also same problem. Thanks in advance.

Change History

comment:1 Changed 3 years ago by jomyjohn

I got the solution . change the _getDaysInMonth to the following

_getDaysInMonth: function(year, month) {

return 32 - this._daylightSavingAdjust(new Date(year, month, 32)).getDate();

},

comment:2 Changed 3 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Datepicker: Account for daylight saving when calculating number of days in a month. Fixes #6978 - In Calender for march 2011 dates showing till 5th only.

Thanks jomyjohn

Changeset: c44818fccaeb4f41fdb8b8a00662169a4258b78c

comment:3 Changed 3 years ago by Scott González

Datepicker: Account for daylight saving when calculating number of days in a month. Fixes #6978 - In Calender for march 2011 dates showing till 5th only.

Thanks jomyjohn (cherry picked from commit c44818fccaeb4f41fdb8b8a00662169a4258b78c)

Changeset: 9162679e1589e6883cee0ec462bce5e20ef47ec7

comment:4 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.10

comment:5 Changed 22 months ago by mikesherov

#5696 is a duplicate of this ticket.

comment:6 Changed 22 months ago by mikesherov

#6231 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.