Ticket #6979 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Several components are leaking variables into the global scope

Reported by: Licensed to Gil Owned by:
Priority: minor Milestone: 1.8.19
Component: [meta] ui.dev Version: 1.8.9
Keywords: Cc:
Blocking: Blocked by:

Description

I've found leaked global vars in the pulsate and size effects, as well as the accordion and slider widgets - mostly caused by using ; instead of , in var declarations. GitHub pull request is coming - I need a bug number first ;)

This is filed under effects because I didn't think it was worth putting in three tickets for the three separate components when it's only a tiny fix in each file.

Change History

comment:1 Changed 3 years ago by Licensed to Gil

Submitted pull request on GitHub:  https://github.com/jquery/jquery-ui/pull/122

comment:2 Changed 3 years ago by scott.gonzalez

  • Component changed from effects.* (individual effect) to [meta] ui.dev

comment:3 Changed 3 years ago by Gilmore Davidson

  • Status changed from new to closed
  • Resolution set to fixed

Fixed #6979 - Several components are leaking variables into the global scope

Changeset: 9626484dd5216f7597d4bb9680c95b9b210bac15

comment:4 Changed 2 years ago by scott.gonzalez

#8227 is a duplicate of this ticket.

comment:5 Changed 2 years ago by felix

this is a fix for 1-8-stable  https://github.com/jquery/jquery-ui/pull/622

comment:6 Changed 2 years ago by felix

Fixes #6979 - Several components are leaking variables into the global scope.

Changeset: 6fb584e7007bb7dc539d9c7266d17833c52a7830

comment:7 Changed 2 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.19
Note: See TracTickets for help on using tickets.