Ticket #7086 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

easing only first click is working.

Reported by: David.Sullivan Owned by:
Priority: minor Milestone: 1.8.11
Component: [meta] ui.demos Version: 1.8.10
Keywords: Cc:
Blocking: Blocked by:

Description

On the page  http://jqueryui.com/demos/effect/easing.html page Google Chrome 11 dev build only shows the easing effect for the first item clicked. All other items clicked basicaly just do a .hide. Works correct in FF and IE and Chrome 10.

Change History

comment:1 Changed 3 years ago by David.Sullivan

ajpiano also reproduced this issue I believe.

comment:2 Changed 3 years ago by ajpiano

  • Component changed from ui.core to [meta] ui.demos

It's only reproducible in Chrome 11. But it's also worth noting that the easing demos behave differently in FF versus Safari - in FF, they shrink in both directions, whereas in Safari they only shrink vertically. But this all might get cleaned up by the effects rewrite...

comment:4 Changed 3 years ago by gnarf

  • Status changed from new to closed
  • Resolution set to fixed

Effects demo: Animate a containing div instead of the canvas directly for easing demo. Fixes #7086 - easing only first click is working.

Canvas seems to be animating poorly in Chrome 11 - and animating the height only is scaling width too in some browsers yet not others...

Changeset: fa7f5d2873b1fef978eab7d9f342c5afa77e061c

comment:5 Changed 3 years ago by gnarf

Effects demo: Animate a containing div instead of the canvas directly for easing demo. Fixes #7086 - easing only first click is working.

Canvas seems to be animating poorly in Chrome 11 - and animating the height only is scaling width too in some browsers yet not others... (cherry picked from commit fa7f5d2873b1fef978eab7d9f342c5afa77e061c)

Changeset: 6bd5c08a1d3f28976ef2fb8c31988cd9c18ee055

comment:6 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.11
Note: See TracTickets for help on using tickets.