Ticket #7118 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Jquery UI IE Bug Large ComboBox (Dialog)

Reported by: fernando1124 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.10
Keywords: Cc:
Blocking: Blocked by:

Description

When i make a dialog with a <div> who has a inside combobox(<select>) with many items, like 1000. it makes the dialog but when you try to dropdown the combo in IE it shows the message:

"a script on this page is causing internet explorer to run slowly"

I have tested IE 6 and IE 8 and the problems persist. In Firefox and Chrome it works fine.

I have tried with other versions of ui and the problem persist.

Here is a link to a test case i did in jsFiddle.  http://jsfiddle.net/5ckHU/

Change History

comment:1 Changed 4 years ago by fracmak

This is actually a glitch with the resizable that the dialog uses, more deeply it's an issue with the mouse handler and how it decides if you've clicked on the cancel object.

fixed in pull request  https://github.com/jquery/jquery-ui/pull/309

comment:2 Changed 4 years ago by fracmak

This is also a duplicate of #6644

comment:3 Changed 4 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 Changed 4 years ago by Jay Merrifield

  • Resolution changed from duplicate to fixed

Mouse: Optimize the cancel locator, works around a bug where .add(event.target) in IE8 can take a long time when there are multiple siblings. Fixes #7118 - IE Bug Large ComboBox (Dialog)

Changeset: 09e88d6220af2f90197c826ac3a31a0ca97f2c8f

comment:5 Changed 4 years ago by Jay Merrifield

Mouse: Optimize the cancel locator, works around a bug where .add(event.target) in IE8 can take a long time when there are multiple siblings. Fixes #7118 - IE Bug Large ComboBox (Dialog) (cherry picked from commit 09e88d6220af2f90197c826ac3a31a0ca97f2c8f)

Changeset: b04c6ece34a57840cce22e8680e9bb7a766994df

comment:6 Changed 4 years ago by scott.gonzalez

#6644 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.