Ticket #7176 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Datepicker shows only single year in year dropdown if numberOfMonths > 1

Reported by: toebens Owned by:
Priority: minor Milestone: 1.8.12
Component: ui.datepicker Version: 1.8.11
Keywords: Cc:
Blocking: Blocked by:

Description

hi, i'm using jquery 1.4.4 with latest stable ui (1.8.11). when having a datepicker on a site and set the options:

numberOfMonths: 3,
changeMonth: true,
changeYear: true,
yearRange : '2007:2015'

the year dropdown only shows the current year.

if you set numberOfMonths to 1 it works - then it shows the options 2007 to 2015 in the select list.

 http://jsfiddle.net/A6zPd/

Change History

comment:1 Changed 4 years ago by toebens

the dropdown contains only the currently shown year of the calendar. i tested this with the following browser: Flock 2.5.6 Firefox 3.6.15

although in IE9, Opera 11.01 and safari 5.0.4 (7533.20.27) the dropdown is filled correctly!

comment:2 Changed 4 years ago by scott.gonzalez

#7194 is a duplicate of this ticket.

comment:4 Changed 4 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Datepicker: Only generate yearshtml once. Fixes #7176 - Datepicker shows only single year in year dropdown if numberOfMonths > 1.

Changeset: 98c53d8432990f2c674e3a1274141b64a87d8ee9

comment:5 Changed 4 years ago by Scott González

Datepicker: Only generate yearshtml once. Fixes #7176 - Datepicker shows only single year in year dropdown if numberOfMonths > 1. (cherry picked from commit 98c53d8432990f2c674e3a1274141b64a87d8ee9)

Changeset: a8fc3da62885c2d7c692e24f8416e320886e1e7b

comment:6 Changed 4 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.12

comment:7 Changed 4 years ago by scott.gonzalez

#7247 is a duplicate of this ticket.

comment:8 Changed 3 years ago by scott.gonzalez

#7709 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.