Ticket #7226 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Dialog buttons badly handled with JQuery 1.3.2

Reported by: aperitero Owned by:
Priority: blocker Milestone: 1.8.12
Component: ui.dialog Version: 1.8.11
Keywords: Cc:
Blocking: Blocked by:

Description

As I understand it, the "1.3.2+" requirement for UI 1.8.11 means that it should work with JQuery 1.3.2.

However, the dialog buttons are not correctly handled with this version of JQuery: the click function is executed as soon as the dialog box is created, the label is not displayed.

Here is a test case to reproduce the bug:  http://jsfiddle.net/nDwqF/3/

Here is a possible correction:  https://github.com/aperitero/jquery-ui/commit/552c75b92a51dda5e0d212f5fd3a90e6a00e3960

Change History

comment:1 Changed 3 years ago by scott.gonzalez

  • Priority changed from minor to blocker
  • Status changed from new to open
  • Milestone changed from 1.9 to 1.8.12

comment:2 Changed 3 years ago by Scott González

  • Status changed from open to closed
  • Resolution set to fixed

Dialog: Don't use .attr( props, true ) for creating buttons since that API doesn't exist in jQueery 1.3.2. Fixes #7226 - Dialog buttons badly handled with JQuery 1.3.2.

Changeset: e388153049503255810d4a871e06e9930de74c70

comment:3 Changed 3 years ago by aperitero

Prompt correction! Thanks a lot!

Note: See TracTickets for help on using tickets.