Ticket #7293 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Resizable: Chrome dev tools console shows GET data: undefined (undefined)

Reported by: jerry Owned by: rdworth
Priority: minor Milestone: 1.8.13
Component: ui.resizable Version: 1.8.12
Keywords: Cc:
Blocking: Blocked by:

Description (last modified by rdworth) (diff)

When you initialize a resizable element in Chrome, there is a broken image resource, observable in the developer tools console:

X Failed to load resource

or

X GET data:

or

GET data: undefined (undefined)

Change History

comment:1 Changed 4 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to worksforme

Please provide a reduced test case showing the problem.

comment:2 Changed 4 years ago by i8beef

I see this too. Running Chrome, while watching the JS console, I see this error come up as soon as $().dialog() get's called., on JQuery UI 1.8.12.

comment:3 Changed 4 years ago by rdworth

  • Status changed from closed to reopened
  • Resolution worksforme deleted
  • Component changed from ui.dialog to ui.resizable
  • Description modified (diff)
  • Summary changed from GET data: undefined (undefined) in Dialog to Resizable: Chrome dev tools console shows GET data: undefined (undefined)

comment:4 Changed 4 years ago by rdworth

  • Description modified (diff)

comment:5 Changed 4 years ago by rdworth

  • Description modified (diff)

comment:6 Changed 4 years ago by rdworth

  • Owner set to rdworth
  • Status changed from reopened to assigned

This error was caused by the fix for #7233 . It seems chrome wants a valid image in a background:url(data:... and complains if it doesn't get one. Found a better fix (transparent 1x1px gif) at  http://code.google.com/p/jqtouch/issues/detail?id=228 and tested data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs= in latest Chrome and IE6 . Works.

comment:7 Changed 4 years ago by Richard Worth

  • Status changed from assigned to closed
  • Resolution set to fixed

Resizable: switch data: background image to valid image file, small 1px transparent gif. Fixed #7293 - Resizable: Chrome dev tools console shows GET data: undefined (undefined)

Changeset: 5058ac3ce7a45c5823f4c108b0ae3ae45346d0f8

comment:8 Changed 4 years ago by Richard Worth

Resizable: switch data: background image to valid image file, small 1px transparent gif. Fixed #7293 - Resizable: Chrome dev tools console shows GET data: undefined (undefined) (cherry picked from commit 5058ac3ce7a45c5823f4c108b0ae3ae45346d0f8)

Changeset: 5e095e9f4cf0ebd1593183b1df7413031f1990fb

comment:9 Changed 4 years ago by rdworth

  • Milestone changed from 1.9 to 1.8.13
Note: See TracTickets for help on using tickets.