Ticket #7623 (closed bug: fixed)

Opened 3 years ago

Last modified 14 months ago

DatePicker reappears after selection in ie8

Reported by: jbblanchet Owned by:
Priority: minor Milestone: 1.8.15
Component: ui.datepicker Version: 1.8.15
Keywords: Cc:
Blocking: Blocked by:

Description

To reproduce, create an html file with a standard DatePicker and open it in ie8. Click on the field to bring up the date picker and select a date. The date picker will reopen immediatly.

This doesn't happen with 1.8.14. Happens in ie8 but fine in FireFox.

Change History

comment:1 Changed 3 years ago by maxpayne

In IE 7 as well the examples in  http://jqueryui.com/demos/datepicker/ have the same effect. It reappears again, After date is selected.

comment:2 Changed 3 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Datepicker: Revert "Datepicker: Removing unnessecary typeof check. Fixed #6669 - Datepicker: _selectDate restores focus to non-object" Fixes #7623 - DatePicker reappears after selection in ie8.

This reverts commit 5f0a2f01c4609315ab66158191d3f9bd420f827f.

Changeset: bb79b418717bbd4b2ae800fc8c6bbe39682a2283

comment:3 Changed 3 years ago by Scott González

Datepicker: Revert "Datepicker: Removing unnessecary typeof check. Fixed #6669 - Datepicker: _selectDate restores focus to non-object" Fixes #7623 - DatePicker reappears after selection in ie8.

This reverts commit 86a09aeb332851971bc2b2ce6bbf4d4292b12020.

Changeset: 7c15d3c19f9cdde9cc82ac0486a93b01ec03eb6b

comment:4 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.16

comment:5 Changed 3 years ago by scott.gonzalez

#7627 is a duplicate of this ticket.

comment:6 Changed 3 years ago by scott.gonzalez

#7642 is a duplicate of this ticket.

comment:7 Changed 3 years ago by scott.gonzalez

#7644 is a duplicate of this ticket.

comment:8 Changed 3 years ago by scott.gonzalez

#7646 is a duplicate of this ticket.

comment:9 Changed 14 months ago by mikesherov

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone changed from 1.8.16 to none

comment:10 Changed 14 months ago by mikesherov

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Milestone changed from none to 1.8.15
Note: See TracTickets for help on using tickets.