Ticket #7911 (closed bug: wontfix)

Opened 3 years ago

Last modified 3 years ago

Button: icon only button in dialog causes horizontal scrollbar in Opera

Reported by: PatrickM Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.button Version: 1.8.16
Keywords: Cc:
Blocking: Blocked by:

Change History

comment:1 Changed 3 years ago by rdworth

comment:3 Changed 3 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Button: Apply overflow: hidden in all browsers except IE 6,7 to avoid expanding the size of the button from negative text indent. Fixes #7911 - Button: icon only button in dialog causes horizontal scrollbar in Opera.

Changeset: a3a5c65d4dd9eb6be0e8a71d82c3ca86b38ed009

comment:4 Changed 3 years ago by Scott González

Button: Apply overflow: hidden in all browsers except IE 6,7 to avoid expanding the size of the button from negative text indent. Fixes #7911 - Button: icon only button in dialog causes horizontal scrollbar in Opera. (cherry picked from commit a3a5c65d4dd9eb6be0e8a71d82c3ca86b38ed009)

Changeset: 005709f432327ae672f7a613a8dca6200febe017

comment:5 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.18

comment:6 Changed 3 years ago by Scott González

Revert "Button: Apply overflow: hidden in all browsers except IE 6,7 to avoid expanding the size of the button from negative text indent. Fixes #7911 - Button: icon only button in dialog causes horizontal scrollbar in Opera."

This reverts commit a3a5c65d4dd9eb6be0e8a71d82c3ca86b38ed009.

Changeset: 99fd8511ed4098a4cbf6c66999ef4df0bd8280be

comment:7 Changed 3 years ago by Scott González

Revert "Button: Apply overflow: hidden in all browsers except IE 6,7 to avoid expanding the size of the button from negative text indent. Fixes #7911 - Button: icon only button in dialog causes horizontal scrollbar in Opera."

This reverts commit a3a5c65d4dd9eb6be0e8a71d82c3ca86b38ed009. (cherry picked from commit 99fd8511ed4098a4cbf6c66999ef4df0bd8280be)

Changeset: 959e36bfc47ac8992e805aa34b736876e0e926cd

comment:8 Changed 3 years ago by scott.gonzalez

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone changed from 1.8.18 to 1.9

Reverted fix because it caused a more serious regression in Firefox:  https://forum.jquery.com/topic/different-position-of-button-and-checkbox-in-toolbar

comment:9 Changed 3 years ago by scott.gonzalez

  • Status changed from reopened to closed
  • Resolution set to wontfix

The bug in Opera no longer exists with Opera 11.6.

Note: See TracTickets for help on using tickets.