Ticket #8135 (open bug)

Opened 2 years ago

Last modified 17 months ago

Horizontal sortable shifts causes elements to shift down

Reported by: bertjh Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.17
Keywords: Cc:
Blocking: Blocked by:

Description

When creating a horizontal scrollable using "display: inline-block", moving an element - which will activate the placeholder - causes the li-elements to shift down.

Demo:  http://jsfiddle.net/Bertjh/rTTMF/5/

Change History

comment:1 Changed 2 years ago by Bertjh

  • Status changed from new to closed
  • Resolution set to fixed

Sortable: modified the contents of placeholder to a single " ". Fixed #8135 - sortable: Horizontal sortable shifts causes elements to shift down.

Changeset: b6e1f25ab8c038306146a6ead041dc18bfb9e8c2

comment:2 Changed 2 years ago by Bertjh

Sortable: modified the contents of placeholder to a single " ". Fixed #8135 - sortable: Horizontal sortable shifts causes elements to shift down. (cherry picked from commit b6e1f25ab8c038306146a6ead041dc18bfb9e8c2)

Changeset: f0b7130a5459d9f34b1e05ad6306d3909131bd8c

comment:3 Changed 2 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.19

comment:4 Changed 2 years ago by Scott González

Revert "Sortable: modified the contents of placeholder to a single " ". Fixed #8135 - sortable: Horizontal sortable shifts causes elements to shift down."

This reverts commit b6e1f25ab8c038306146a6ead041dc18bfb9e8c2.

Changeset: b38dd26da0a7297941839195ff75885d6ecc67d0

comment:5 Changed 2 years ago by scott.gonzalez

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone changed from 1.8.19 to 1.9

This was causing too many regressions.

comment:6 Changed 2 years ago by Scott González

  • Status changed from reopened to closed
  • Resolution set to fixed

Revert "Sortable: modified the contents of placeholder to a single " ". Fixed #8135 - sortable: Horizontal sortable shifts causes elements to shift down."

This reverts commit b6e1f25ab8c038306146a6ead041dc18bfb9e8c2. (cherry picked from commit b38dd26da0a7297941839195ff75885d6ecc67d0)

Changeset: 1ffafe65b0dd2d8b0ae4dfcfe3beffb3123c7caf

comment:7 Changed 2 years ago by scott.gonzalez

  • Status changed from closed to reopened
  • Resolution fixed deleted

silly Trac/GitHub integration...

comment:8 Changed 23 months ago by scott.gonzalez

  • Milestone changed from 1.9.0 to 2.0.0

comment:9 Changed 22 months ago by mikesherov

  • Status changed from reopened to open

comment:10 Changed 22 months ago by scott.gonzalez

#8407 is a duplicate of this ticket.

comment:11 Changed 17 months ago by tj.vantoll

Reduced test case against master showing the 2 workarounds mentioned:  http://jsfiddle.net/tj_vantoll/vfgb5/.

Note: See TracTickets for help on using tickets.