Ticket #8416 (closed bug: fixed)

Opened 2 years ago

Last modified 2 years ago

Draggable breaks during drag if any other draggable is removed or destroyed

Reported by: brennan.roberts Owned by:
Priority: minor Milestone: 1.8.23
Component: ui.draggable Version: 1.8.21
Keywords: Cc:
Blocking: Blocked by:

Description

 http://jsfiddle.net/6mYLB/4/

If any draggable is deleted or destroyed while any other draggable is mid-drag, that drag breaks. By rolling back, it looks like this was introduced in 1.8.19.

jQuery UI 1.8.21 jQuery 1.7.2 Chrome 20 Firefox 13

Change History

comment:1 Changed 2 years ago by brennan.roberts

Oops, that fiddle needed some commentary:  http://jsfiddle.net/6mYLB/10/

comment:2 Changed 2 years ago by brennan.roberts

This persists in 1.8.22. It's surprising that no one else has chimed in here, as this would seem a breaking bug for any real-time application containing draggables. Is this ticket a duplicate?

Last edited 2 years ago by brennan.roberts (previous) (diff)

comment:3 Changed 2 years ago by scott.gonzalez

  • Status changed from new to open

This is caused by a76366f8fc731ec6946d9f6940c8a03040e31d23. The new uuid for _on() should fix this, but only exists in master.

comment:4 Changed 2 years ago by Scott González

  • Status changed from open to closed
  • Resolution set to fixed

Mouse: Don't try to unbind delegated event handlers if they don't exist. Fixes #8416 - Draggable breaks during drag if any other draggable is removed or destroyed.

Changeset: e68bee9b84b16ee8a757a7a1f44d93f4ba78c656

comment:5 Changed 2 years ago by Scott González

Mouse: Don't try to unbind delegated event handlers if they don't exist. Fixes #8416 - Draggable breaks during drag if any other draggable is removed or destroyed. (cherry picked from commit e68bee9b84b16ee8a757a7a1f44d93f4ba78c656)

Changeset: 25f20b18bd43dd4259b64e016d397ba45f5c6934

comment:6 Changed 2 years ago by scott.gonzalez

  • Milestone changed from 1.9.0 to 1.8.23
Note: See TracTickets for help on using tickets.