Opened 6 years ago

Closed 6 years ago

#10042 closed bug (duplicate)

Dialog: "unspecified error" when using ie9 and iframe

Reported by: msaiz Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

Sorry for reporting this again, but I couldn't find a way to reopen ticket #8443.

I've updated my install to jqueryui version 1.10.4.

However, I'm having the same problem (en ie9, inside an iframe) in the dialog "dialog.open" method

As far as I see, the correction was only for the "dialog.close" method.

Problem still happens in line 232.

https://github.com/jquery/jquery-ui/blob/1-10-stable/ui/jquery.ui.dialog.js#L232

Sorry, but I can't post a "minimum example" right now.

I solved it like this:

try {

this.opener = $(this.document[0].activeElement);

} catch( e ) {

this.opener = $(document.body);

}

Change History (1)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9823.

Note: See TracTickets for help on using tickets.