Skip to main content

Search and Top Navigation

#10110 closed bug (fixed)

Opened June 13, 2014 06:03PM UTC

Closed June 25, 2014 02:46AM UTC

Build: bower.json cannot artificially limit jquery versions

Reported by: scottgonzalez Owned by:
Priority: blocker Milestone: 1.11.0
Component: [meta] Version: 1.11.0-beta.2
Keywords: Cc:
Blocked by: Blocking:

We have bower.json set to mark jquery as a dependency with versions >=1.6 <1.11. We do this so that we get a copy of jQuery 1.x in our repo, instead of a copy of jQuery 2.x. However, this prevents users from using a newer version of jQuery since Bower will say that it's not compatible.

Attachments (0)
Change History (3)

Changed June 13, 2014 06:06PM UTC by scottgonzalez comment:1

milestone: none1.11.0
priority: minorblocker
status: newopen

Changed June 16, 2014 02:22PM UTC by jzaefferer comment:2

Changed June 25, 2014 02:46AM UTC by Scott González comment:3

resolution: → fixed
status: openclosed

Bower: Change jquery dependency to >=1.6 (don't limit max version)

Fixes #10110

Closes gh-1266

Changeset: a0fea7d849a2d0a949cfde8ea1c2edbf2a94d963