Opened 3 years ago

Closed 3 years ago

#10351 closed bug (fixed)

Changes to ui in callbacks no longer have any effect

Reported by: mathrick Owned by:
Priority: major Milestone: 1.11.1
Component: ui.resizable Version: 1.11.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

Previously, callbacks could influence the ongoing resize by changing the passed ui object. This could be used to constraint the resize dynamically (such as in http://stackoverflow.com/questions/5087262/jquery-ui-resizable-stop-resizing-in-the-resize-event). This is no longer possible.

The change happened between 1.9 and 1.10, and seems to be related to #5817 and [3974b55ba5078799df818c78d9273e11d9796ff3]. I don't understand the logic enough, however, to be able to pinpoint the exact where it did/doesn't happen, so I can't verify if it was the exact commit that changed it. In any case, the effect can be easily reproduced in the fiddle linked in one of the answers by plugging in different versions of JqueryUI. http://jsfiddle.net/PrEfd/84/ has 1.11 and shows how the technique no longer works.

Change History (3)

comment:1 Changed 3 years ago by Scott González

Keywords: regression added
Milestone: none1.11.1
Priority: minormajor
Status: newopen

comment:3 Changed 3 years ago by Scott González

Resolution: fixed
Status: openclosed

Resizable: Fix size/position changes in resize event

Fixes #10351 Closes gh-1292

Changeset: 5beae72e7773d35d46195a4359cb8f845dfb0f4f

Note: See TracTickets for help on using tickets.