Opened 5 years ago

Closed 5 years ago

#10540 closed bug (duplicate)

open a modal dialog inside another modal dialog

Reported by: gabrha Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.11.0
Keywords: Cc:
Blocked by: Blocking:

Description

i'm using JQuery v2.1.1 and JQuery UI v1.11.0, i'm trying to open a modal dialog inside another one, with the first (parent) dialog disabled as the background.

In both dialog the modal properties is true, but only the background in disabled, not the first dialog.

This is the HTML:

<div id="dialog-first" title="1st Modal">
    First Modal
    <input type="text" id="onetext"/>
</div>

<div id="dialog-second" title="2nd Modal">
    Second Modal
</div>

And the JS:

$( "#dialog-first" ).dialog({
    height: 300,
    modal: true,
    buttons: {
        Cancel: function() {
            $(this).dialog('close');
        }
    }
});

$( "#dialog-second" ).dialog({
    autoOpen: false,
    modal: true,
    buttons: {
        Cancel: function() {
            $(this).dialog('close');
        }
    }
});

$("#onetext").dblclick(function() {
    $("#dialog-second").dialog("open");
});

For test, i wrote the code at: http://jsfiddle.net/33PQj/

Change History (1)

comment:1 Changed 5 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #10138.

Note: See TracTickets for help on using tickets.