Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10138 closed bug (fixed)

Dialog: Nested modal dialogs are not modal

Reported by: Goswinus Owned by:
Priority: minor Milestone: 1.11.1
Component: ui.dialog Version: 1.11.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

When opening a dialog from a dialog, both with {modal: true}, the second dialog is not modal.

See this simple example: http://jsbin.com/japuxogi/1/edit.

-Click on the first button to open the first dialog.
-Click on the second button to open the second dialog.
-Move the second dialog (to expose the title bar of the (underlaying) first dialog.
-Click on the title bar of the first dialog

This should be impossible because the second dialog is modal! You can even close the first dialog with the second dialog still being "open".

Change History (7)

comment:1 Changed 3 years ago by tj.vantoll

  • Status changed from new to open
  • Summary changed from Nested modal dialog is not modal to Dialog: Nested modal dialogs are not modal

Confirmed. This regressed in 1.11 as the test case works with 1.10.4.

comment:2 Changed 3 years ago by scottgonzalez

  • Keywords regression added

comment:4 Changed 3 years ago by Scott González

  • Resolution set to fixed
  • Status changed from open to closed

Dialog: Fix stacking of modal dialog overlays

Fixes #10138 Closes gh-1286

Changeset: acfda4be521e48c6b61cc458a715ef163892ac36

comment:5 Changed 3 years ago by scottgonzalez

  • Milestone changed from none to 1.11.1

comment:6 Changed 3 years ago by scottgonzalez

#10487 is a duplicate of this ticket.

comment:7 Changed 3 years ago by tj.vantoll

#10540 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.