Opened 5 years ago

Closed 5 years ago

#10542 closed bug (wontfix)

Autocomplete: up/down arrow do a select on Ubuntu (maybe others?)

Reported by: fscherma Owned by: fscherma
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Since probably an upgrade of Chromium on my Ubuntu 14.04 now arrow keys directly select the element. It works with Firefox and was ok with the previous version of Chromium.

The test case is very easy :http://api.jqueryui.com/autocomplete/#entry-examples

Type 'C' and down arrow key, wait 500ms and you will have the issue...

Change History (9)

comment:1 Changed 5 years ago by tj.vantoll

Owner: set to fscherma
Status: newpending

Hi fscherma,

Thanks for taking the time to contribute to jQuery UI. This works fine on OS X, and I don't have an Ubuntu install to test this on. What specifically happens after 500ms? Do you get an error, or does the option automatically get selected, or...?

comment:2 Changed 5 years ago by fscherma

Status: pendingnew

I've said 500ms because its the delay param of the example. Yes the element is selected (content set to the input field) and no possibilities to select the others choices.

comment:3 Changed 5 years ago by tj.vantoll

Hey fscherma,

Unfortunately we're having a hard time finding someone with an Ubuntu install. So at the moment we can't recreate the problem to look into this.

comment:4 Changed 5 years ago by tj.vantoll

Status: newopen
Summary: up/down arrow do a select on Chromium 36+Autocomplete: up/down arrow do a select on Ubuntu (maybe others?)

We were able to recreate the problem intermittently, so I'll mark this as valid for now.

comment:5 Changed 5 years ago by cgack

fscherma - In my testing I could intermittently get similar behavior from what you describe but want to verify something.

Are you stating that to reproduce you are using <shift>+c (Uppercase C) and then using the down arrow key? Or is this happening all the time no matter what letter or case the letter is and regardless of whether or not you use the shift key? Thanks.

comment:6 Changed 5 years ago by fscherma

Good news :)

I've wrote 'C' (because their is many choices displayed with 'C' but any others will do the case. Until you don't wait for the delay between pressing an arrow key, you can navigate to others choices. You have to wait 500ms after released an arrow to reproduce everytime this issue.

comment:7 Changed 5 years ago by Scott González

#10564 is a duplicate of this ticket.

comment:8 Changed 5 years ago by fscherma

Since upgrade of Chromium Version 37.0.2062.120 Ubuntu 14.04 (281580) (64-bit) the issue is solved.

comment:9 Changed 5 years ago by Scott González

Resolution: wontfix
Status: openclosed

Great. I'll close this as won't fix then.

Note: See TracTickets for help on using tickets.