Opened 5 years ago

Closed 5 years ago

#10564 closed bug (duplicate)

Autocomplete chrome, keyboard navigation selects the option

Reported by: juzerali Owned by: juzerali
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

Chrome version 36.x and 38.x

Reproduces on https://jqueryui.com/autocomplete website.

Steps to reproduce

  • in autocomplete field type a letter, say 'a'.
  • navigate using keyboard
  • stay on an option for delay milliseconds. Basically same amount of time as configured in delay variable

Expected behavior : Option should not get selected unless enter key is pressed or mouse in clicked on an option

What happens instead : The option on which you stay while navigating with keyboard, gets selected and other options disappear.

Change History (4)

comment:2 Changed 5 years ago by Scott González

Owner: set to juzerali
Status: newpending

The bin is using a very old version of jQuery UI and I'm not seeing the bug with either the old version or the current version.

comment:3 in reply to:  2 Changed 5 years ago by juzerali

Status: pendingnew

Replying to scott.gonzalez:

The bin is using a very old version of jQuery UI and I'm not seeing the bug with either the old version or the current version.

I can reproduce the bug on https://jqueryui.com/autocomplete, don't you? Additional info, I am on Ubuntu 14.04.

comment:4 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #10542.

Note: See TracTickets for help on using tickets.