Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10590 closed bug (fixed)

Resizable: Issue with grid and resizing in one direction

Reported by: mnadalin Owned by: mikesherov
Priority: minor Milestone: 1.11.3
Component: ui.resizable Version: 1.11.1
Keywords: regression Cc:
Blocked by: Blocking:

Description

See it in action: http://jsfiddle.net/mnadalin/cnpf1gn4/2/

click on any box to place a new div. Works correctly when resizing from east, but when resizing from west is not possibile to obtain the midwidth: 0 or 2 x grid width.

Change History (9)

comment:1 Changed 3 years ago by tj.vantoll

Owner: set to mnadalin
Status: newpending

Hi mnadalin,

This appears to be caused by you setting the grid option to [33, 1]. If I change the 1 to some larger value the problem goes away (see http://jsfiddle.net/tj_vantoll/cpvatbh8/). Can you confirm?

comment:2 Changed 3 years ago by mnadalin

Status: pendingnew

Hello,

Not at all. Testing the code on your link if i place a new resizable div (clicking on any slot in the grid) and try to extend it from the west side it grows on the top and does not take care of the grid width. I'm looking at the source, it seems that in the w resize some parameters are used in the wrong way. Right?

comment:3 Changed 3 years ago by tj.vantoll

Keywords: regression added
Status: newopen
Summary: W Handle not respecting the minWidth parameterResizable: Issue with grid and resizing in one direction

Ok thanks. I was able to reduce this significantly: http://jsfiddle.net/tj_vantoll/cnpf1gn4/7/. This isn't related to minWidth, but it has something to do with the grid option, and it regressed in 1.11.1.

comment:4 Changed 3 years ago by mnadalin

Seems so, but using 33 as grid width the problem persist because the box can be resized to 1 px width.

comment:5 Changed 3 years ago by mikesherov

Owner: changed from mnadalin to mikesherov
Status: openassigned

comment:6 Changed 3 years ago by Mike Sherov

Resolution: fixed
Status: assignedclosed

Resizable: correct width when grid approaches zero

Fixes #10590

Changeset: 9493839f23b6ff71aacb9cb8fe8fde6c8d0ecd61

comment:7 Changed 3 years ago by mikesherov

Milestone: none1.12.0

comment:8 Changed 3 years ago by Mike Sherov

Resizable: correct width when grid approaches zero

Fixes #10590 (cherry picked from commit 9493839f23b6ff71aacb9cb8fe8fde6c8d0ecd61)

Changeset: 0a0db09378fb21ef37fa261958d89f7f1a21ba76

comment:9 Changed 3 years ago by Scott González

Milestone: 1.12.01.11.3
Note: See TracTickets for help on using tickets.