Opened 5 years ago

Closed 5 years ago

#10633 closed bug (duplicate)

Bug in JQuery UI Menu using Cupertino & other themes with icons

Reported by: Justin Levene Owned by:
Priority: minor Milestone: none
Component: ui.menu Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

When using the Cupertino theme and sub menus, the icons in the sub menu get the state of the root menu item and go white.

In the fiddle below, select "Edit" then hover over any item in the sub menu and all the icons in that sub-menu then go white and invisible.

http://jsfiddle.net/jplevene/wkk8e902/4/

Change History (2)

comment:1 Changed 5 years ago by Justin Levene

When using the Cupertino theme and sub menus, the icons in the sub menu inherit the state of the root menu item and go white with a ui-state-active instead of a ui-state-focus or no state like the rest of the sub-menu.

In the fiddle below, select "Edit" then hover over any item in the sub menu and all the icons in that sub-menu then go white and invisible when the mouse goes over any single sub-menu items as though they were all ui-state-active.

http://jsfiddle.net/jplevene/wkk8e902/4/

Last edited 5 years ago by Justin Levene (previous) (diff)

comment:2 Changed 5 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #10162.

Note: See TracTickets for help on using tickets.