Opened 3 years ago

Closed 3 years ago

#10639 closed bug (fixed)

Selectmenu: Cannot typeahead when menu is open

Reported by: tj.vantoll Owned by:
Priority: blocker Milestone: 1.11.2
Component: ui.selectmenu Version: 1.11.1
Keywords: regression Cc:
Blocked by: Blocking:

Description

In 1.11.0 you could click on a selectmenu's button, and then start typing to autocomplete options. That functionality broke in 1.11.1 as the selectmenu no longer receives focus when you click the button.

Change History (6)

comment:1 Changed 3 years ago by tj.vantoll

Keywords: regression added
Status: newopen

comment:2 Changed 3 years ago by Scott González

Milestone: none1.11.2
Priority: minorblocker

comment:3 Changed 3 years ago by tj.vantoll

This was caused by https://github.com/jquery/jquery-ui/commit/749a6a56677fe29d2bf777d79811ce8bdd1b5fad. I can't come up with a way to allow the functionality described in #10144, and to allow typeahead for options.

My first thought is to revert that commit as this is a far bigger issue, but I'll play with this a bit.

comment:4 Changed 3 years ago by Jörn Zaefferer

Here's a fiddle that shows the original problem reported in #10144: http://jsfiddle.net/TdLvC/1/

comment:6 Changed 3 years ago by Scott González

Resolution: fixed
Status: openclosed

Selectmenu: Preserve text selection and button focus on click

Fixes #10639 Closes gh-1358

Changeset: d4a437e4b0d91d40eff269a19672a6db9217766e

Note: See TracTickets for help on using tickets.