Opened 5 years ago

Closed 5 years ago

#10734 closed bug (duplicate)

down arrow key doesn't work properly in autocomplete scrolling view when mouse pointer is on one of the display record.

Reported by: neerajnandwana Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.11.2
Keywords: Cc:
Blocked by: Blocking:

Description

Steps:

  • Type 'a' in autocomplete text box, which will show you the drop list of matched records
  • Now move your mouse pointer on one of the display record, so it will highlight the record.
  • Click on "down arrow" key in keyboard to navigate to next record, until you reach the last visible record in the current scroll view. Now if you press one more "down arrow" key then

Expected: it should scroll the view, so next record will be in visible area and it should mark that record as active record

Actual: It is jumping the active record to record which is just below to the mouse pointer.

Version details: jquery-1.10.2.js jquery-ui.js (version: 1.11.2)

Browser details: Chrome Version 39.0.2171.95 m Firefox 34.0

OS: Window-7

Issue reproducible on: Demo Page

Change History (1)

comment:1 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9356.

Note: See TracTickets for help on using tickets.