Opened 6 years ago

Closed 21 months ago

Last modified 21 months ago

#9356 closed bug (fixed)

Menu: Issues with keyboard navigation and scrolling when mouse over the menu

Reported by: etiger13 Owned by: etiger13
Priority: minor Milestone: 1.12.2
Component: ui.menu Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

When the mouse if over the menu and there the list is a scrolling list, the focus gets switched to whats under the mouse when scrolled with the keyboard.

Change History (9)

comment:1 Changed 6 years ago by etiger13

See http://youtu.be/um4XrODR9cY for an example of this happening.

The expected behavior is that the focused item should be the next item "below the "fold" and not switch to another item

comment:2 Changed 6 years ago by Scott González

Owner: set to etiger13
Status: newpending

When an element moves on the page (via scroll, content changes, display changes, etc.), mouse events are triggered if the element that the pointer is hovering changes. There's really nothing sane that can be done here. Do you have a suggestion?

comment:3 Changed 6 years ago by etiger13

Status: pendingnew

i do but you probably won't like it. store the mouse coordinates and then check them before switching focus.

Ignore the horrible spacing: https://gist.github.com/eddiemonge/5702103

comment:4 Changed 6 years ago by tj.vantoll

Status: newopen
Summary: Keyboard navigation when mouse over the menuMenu: Issues with keyboard navigation when mouse over the menu

comment:5 Changed 6 years ago by tj.vantoll

Summary: Menu: Issues with keyboard navigation when mouse over the menuMenu: Issues with keyboard navigation and scrolling when mouse over the menu

comment:6 Changed 4 years ago by Scott González

#10734 is a duplicate of this ticket.

comment:8 Changed 21 months ago by Scott González

Resolution: fixed
Status: openclosed

In 50efd6e1:

Menu: Ignore mouse events triggered due to page scrolling

Fixes #9356
Closes gh-1806

comment:9 Changed 21 months ago by Scott González

Milestone: none1.12.2
Note: See TracTickets for help on using tickets.