Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#11539 closed bug (fixed)

Core: safeBlur breaks in IE11

Reported by: jzaefferer Owned by:
Priority: minor Milestone: git
Component: ui.core Version: git (not yet released)
Keywords: Cc:
Blocked by: Blocking:

Description

This is a regression from a recent change ( https://github.com/jquery/jquery-ui/commit/f33027840cdac5152599da66635981bbe68c6bda ), causing three test suites to fail in IE11. From a recent build:

The error is the same for each:

Unable to get property 'toLowerCase' of undefined or null reference

Source: https://github.com/jquery/jquery-ui/blob/8bcd363ae640bbefc28b720c1ab58b7992ea7044/ui/core.js#L74

Only dialog and draggable use safeBlur. Can't yet tell why element is defined, but element.nodeName isn't.

Change History (10)

comment:1 Changed 22 months ago by scottgonzalez

I can't reproduce the failures even when using the TestSwarm URLs.

comment:2 Changed 22 months ago by jzaefferer

Probably related to the iframe TestSwarm uses. There the error is showing up pretty consistently over multiple builds.

comment:3 Changed 22 months ago by Scott González

  • Resolution set to fixed
  • Status changed from new to closed

Core: Handle IE11 bug with document.activeElement in iframes

Fixes #11539 Closes gh-1518

Changeset: 76c27556f48bea48d3787c241d35e190d46c3245

comment:4 Changed 22 months ago by scottgonzalez

  • Milestone changed from none to git

comment:5 Changed 22 months ago by scottgonzalez

I spent a while trying to reduce this as much as I could, but I gave up after a while. Here's what I came up with: http://jsbin.com/fejituname/1/. It still has a dependency on jQuery Core, but it reliably reproduces the bug.

comment:6 Changed 22 months ago by dmethvin

What should I see from that test case?

comment:7 Changed 22 months ago by scottgonzalez

You should see an alert with an error message in IE11.

comment:8 Changed 22 months ago by dmethvin

I don't see an alert in either real Win8.1+IE11 on Windows or on Win7+IE11 Browserstack.

Did I mention I hate focus?

comment:9 Changed 22 months ago by scottgonzalez

That's because of the new live preview time limit in jsbin :-/ It loads the editor instead of the actual page now.

comment:10 Changed 22 months ago by scottgonzalez

http://jsbin.com/towote/1 is a new clone of the bin with a registered account, so it should work forever.

Note: See TracTickets for help on using tickets.