Opened 5 years ago

Closed 5 years ago

#11612 closed bug (duplicate)

Draggable helper changes position when entering and leaving a Sortable list with relative positioning

Reported by: benyticklez Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.11.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a draggable list that is connected to a sortable list via connectToSortable and everything was working as intended but after the jQuery UI v1.11.2 update the following 2 problems happen:

1) On entering the sortable list the draggable helper slightly repositions in relation to the cursor position.

2) On leaving the sortable list (without dropping in the helper obviously) the draggable helper significantly repositions in relation to the cursor.

The draggable helper used to always stay appended to the body but with the 1.11.2 update it starts appended to the body but when you enter the sortable it is appended to the sortable list, creating a positioning issue.

Here is a JSFiddle highlighting the issue http://jsfiddle.net/bennyticklez/oLowzou6/1/

Change History (1)

comment:1 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #10669.
This is already fixed. Please upgrade to the latest version.

Note: See TracTickets for help on using tickets.