Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#10669 closed bug (fixed)

Draggable: Position issue with connectToSortable

Reported by: creage Owned by:
Priority: minor Milestone: 1.11.4
Component: ui.draggable Version: 1.11.2
Keywords: regression Cc:
Blocked by: Blocking:

Description

Moving a draggable element, connected to a sortable, around containers, makes it positioned unexpected.

http://jsfiddle.net/BW3NW/3/

Try to drag an item from the left (draggable list) to the right list (sortable), but don't place it there, just keep dragging to the right. After you mouse reach the right edge of the right list, your element is positioned unexpectedly.

Tested on Chrome and IE, running jQuery UI 1.11.2.

Change History (12)

comment:1 Changed 2 years ago by tj.vantoll

  • Keywords regression added
  • Status changed from new to open

I reduced this some: http://jsfiddle.net/tj_vantoll/BW3NW/5/. This appears to have regressed in 1.11.2 as I'm not seeing the problem in 1.11.1.

comment:2 Changed 2 years ago by scottgonzalez

  • Version changed from git to 1.11.2

comment:3 Changed 2 years ago by Mike Sherov

  • Resolution set to fixed
  • Status changed from open to closed

Draggable: Ensure parent is correct after dragging through sortable

Fixes #10669

Changeset: d8077dc562bfca60906a160e20186608a10b7a87

comment:4 Changed 2 years ago by mikesherov

  • Milestone changed from none to 1.12.0

comment:5 Changed 2 years ago by mikesherov

#10704 is a duplicate of this ticket.

comment:6 Changed 2 years ago by tj.vantoll

#11250 is a duplicate of this ticket.

comment:7 Changed 2 years ago by Mike Sherov

Draggable: Ensure parent is correct after dragging through sortable

Fixes #10669 (cherry picked from commit d8077dc562bfca60906a160e20186608a10b7a87)

Changeset: b3710631e8d21ef9165ef9f037590e1d250350b4

comment:8 Changed 2 years ago by scottgonzalez

  • Milestone changed from 1.12.0 to 1.11.4

comment:9 Changed 2 years ago by tepez2

There is still an issue when using nested sortables.

Please check this example http://jsfiddle.net/8hy92a9g/1/

  1. Pick up the Thing (draggable)
  2. Drag it in and out of the big red box (sortable) - works as expected
  3. Now drag it in and out of the small blue box (inside the big one). You'll notive that:
    1. When exiting the small box, the helper is flickers for a fraction of a second.
    2. When existing the large box, the helper is misplaced and will remain so until dragging back into the large box.

This is how it looks with Chrome 41 https://www.youtube.com/watch?v=Vls2tTteu60

comment:10 Changed 2 years ago by scottgonzalez

Please file a new issue for the nested case.

comment:12 Changed 2 years ago by scottgonzalez

#11612 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.