Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#12745 closed bug (fixed)

Drop testing on 1.10.1

Reported by: mzgol Owned by: mzgol
Priority: minor Milestone: none
Component: [meta] ui.build Version: git (not yet released)
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery 1.10.2 fixed very few things from 1.10.1, the list is here: http://blog.jquery.com/2013/07/03/jquery-1-10-2-and-2-0-3-released/

One of the fixes was http://bugs.jquery.com/ticket/13980, though which was about cross-domain iframe issues. The problem is TestSwarm loads a cross-domain iframe: the main page is swarm.jquery.org, the frame is on builds.jenkins.jquery.com so it might be causing issues. You can see jQuery UI tests are timing out in all IE versions in jQuery 1.10.1: http://swarm.jquery.org/job/576

The problem is that it doesn't just fail, it starves the available IE pool, making it sometimes harder for other projects to get their tests run on IE.

Considering 1.10.1 & 1.10.2 don't differ too much but one issue may make it harder to run on TestSwarm, maybe you could drop 1.10.1 testing?

Change History (4)

comment:1 Changed 7 years ago by Scott González

Owner: set to mzgol
Status: newpending

This is a new problem with the test setup, so I see no reason to drop this.

comment:2 Changed 7 years ago by mzgol

Status: pendingnew

How new? Tests that time out only on 1.10.1 have been happening at least for 4 weeks: http://swarm.jquery.org/job/377 and UI have failed there even 2 months ago: http://swarm.jquery.org/job/95. TestSwarm history doesn't have any job in which UI would pass tests with Core 1.10.1.

comment:3 Changed 7 years ago by Alexander Schmitz

Resolution: fixed
Status: newclosed

Tests: Stop testing against core 1.10.1 on testswarm

Fixes #12745

Changeset: c2224bf5dc418c84c185844611786b9ccfb869a7

comment:4 Changed 6 years ago by Scott González

In 83ec5e80:

Tests: Stop testing against core 2.0.2 on testswarm

jQuery 2.0.3 fixed very few things from 2.0.2, the list is here:
http://blog.jquery.com/2013/07/03/jquery-1-10-2-and-2-0-3-released/

One of the fixes was ​http://bugs.jquery.com/ticket/13980, though which was
about cross-domain iframe issues. The problem is TestSwarm loads a cross-domain
iframe: the main page is swarm.jquery.org, the frame is on
builds.jenkins.jquery.com so it might be causing issues. You can see jQuery UI
tests are timing out in all IE versions in jQuery 2.0.2:
http://swarm.jquery.org/job/2918

The problem is that it doesn't just fail, it starves the available IE pool,
making it sometimes harder for other projects to get their tests run on IE.

That's why tests with jQuery 2.0.2 on TestSwarm need to be removed as it's been
done with 1.10.1.

Refs #12745
Refs c2224bf5dc418c84c185844611786b9ccfb869a7
Refs gh-1706
Closes gh-1707

Note: See TracTickets for help on using tickets.