Opened 4 years ago

Closed 4 years ago

#14479 closed feature (duplicate)

Support of National (Islamic aka.Hijri and Hebrew) date picker in JQuery

Reported by: shensis Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

For detailed explanation of national (Arabic/Hebrew) calendars please see, for instance, the following reference document.

https://docs.google.com/document/d/1dDrSwimrQbpbXybhMYDEiJXLeeqvelnY4cc8HeCP1Nk/edit?usp=sharing.

The expected functionality of national date pickers to be introduced by this feature is

  1. Classes implementing calendaring logic we expect more or less standard API which should serve following purposes:
  2. Conversion of date represented as a string from one calendaring system to enother
  3. Support integration of calendaring logic into JQuery date picker - https://jqueryui.com/datepicker/

by providing auxiliary methods specific for National calendars.

  1. Date picker (https://jqueryui.com/datepicker/) side is expected to show the date inside date picker (both input field and rectangular area on which usually one month of the calendar is graphically displayed) based on different calendaring systems (type of calendar [Thai, Islamic, Hebrew etc.] can be probably passed as a widget option to date picker widget during creation / initialization.

According to Hebrew cultural preferences, the days ow month as well as year notation should be presented by notation based on letters of Hebrew alphabet. The month names for both Arabic and Hebrew date picker should be specific for each language and presented by letters of corresponding alphabet.

  1. Already now it is clear that at the very least following items are currently missing in JQuery:
  2. Integration of non Gregorian calendar logic into JQuery date picker
  3. National calendars logic propo.
  4. Support for Hebrew numerals in Hebrew calendar (https://en.wikipedia.org/wiki/Hebrew_numerals)
  5. Additional types of non Gregorian calendars

We are willing to contribute those items

Change History (1)

comment:1 Changed 4 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5789.

Note: See TracTickets for help on using tickets.