Opened 3 years ago

Closed 3 years ago

#14915 closed bug (duplicate)

Disabled items are selectable using the keyboard

Reported by: Adam Willden Owned by:
Priority: major Milestone: none
Component: ui.autocomplete Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

Please see the following jsbin: https://output.jsbin.com/womaci

Initially I wanted to create a header. Being able to create a header appears to have been possible in older versions: http://jsfiddle.net/IrvinDominin/rMkER/

When I added a header I found it was selectable. I could override the mouse events but not the keyboard. I found a solution which suggested I could use "ui-state-disabled" as specified in the menu widget documentation. I attempted to create a disabled header item in the hope it would skip selecting the header. This is when I found a secondary issue where disabled items can be selected via the keyboard.

Also I don't believe it should be possible to select disabled items using the keyboard. This may be a problem with the menu widget but looking a the source it appears the autocomplete implementation is not respecting the menu implementation.

Change History (1)

comment:1 Changed 3 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9695.
This is a duplicate of #9695, but also see #9694 which has some more discussion.

Note: See TracTickets for help on using tickets.