Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#9695 closed bug (wontfix)

Autocomplete: should not allow to select a disabled item of its menu with the ENTER key

Reported by: paftek75 Owned by: paftek75
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsbin.com/AyuNiyem/2 (press "a", move with arrow keys and select with ENTER) Disabled cannot be selected with the mouse (the embedded menu widget is doing right here) but is it possible with the keyboard.

Maybe calls of "this.menu.select( event )" should by surrounded by a check of the state of "this.menu.active" ?

Change History (5)

comment:1 Changed 6 years ago by tj.vantoll

Status: newopen
Summary: Autocomplete should not allow to select a disabled item of its menu with the ENTER keyAutocomplete: should not allow to select a disabled item of its menu with the ENTER key

I'm going to mark this as valid as it seems like a legitimate use case and problem to me. At the very least we could make it easy to extend autocomplete to change this behavior; currently it's embedded in a keydown handler deep within _create().

comment:2 Changed 6 years ago by robotdan

comment:3 Changed 6 years ago by Scott González

Owner: set to paftek75
Status: openpending

Here's a one-off implementation showing how to do this with the standard public API: http://jsbin.com/AyuNiyem/4/edit

comment:4 Changed 6 years ago by Scott González

Resolution: wontfix
Status: pendingclosed

And here's an extension that doesn't even let the focus or select events occur for disabled items: http://jsbin.com/AyuNiyem/5/edit

comment:5 Changed 4 years ago by Scott González

#14915 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.