Opened 3 years ago

Closed 3 years ago

#14986 closed bug (duplicate)

jQueryUI 1.11.4 .position() fails with jQuery 3.0.0

Reported by: Martijn van der Lee Owned by:
Priority: minor Milestone: none
Component: ui.position Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

The .position() method of jQueryUI fails with jQuery 3.0.0

https://jsfiddle.net/xe95kx1b/

jQuery dumps an error to console: 'VM206 jquery-3.0.0.js:9779 Uncaught TypeError: elem.getClientRects is not a function'.

The problem seems to be with window, which does not have this function and is used as the default for the within property if the object passed to .position() does not provide a within property, where is is used in the jQuery 3.0.0 .offset() method.

It works okay if the 3.0.0 migrate plugin is loaded but this rather seems to be an incompatibility between the most recent jQuery and jQueryUI versions.

Using following:

  • Chrome Versie 51.0.2704.103 m (64-bit) on Windows 10 (also seems to fail on FireFox).
  • jQuery-3.0.0
  • jQueryUI 1.11.4

Change History (1)

comment:1 Changed 3 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #13493.

Note: See TracTickets for help on using tickets.