Opened 3 years ago

Closed 3 years ago

#14996 closed bug (duplicate)

Button set checked property not set on the highlighted radio input in Firefox

Reported by: Louis-Philippe Perras Owned by:
Priority: minor Milestone: none
Component: ui.button Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

The issue can be reproduced with many versions of Firefox but I did my last tests using Firefox 47.0.1. Here are the steps to reproduce the issue:

  • Navigate to the jQuery button set sample page. (https://jqueryui.com/button/#radio)
  • Launch the developer tools.
  • Select the iframe http://jqueryui.com/resources/demos/button/radio.html at the top right corner.
  • Type this snippet in the console and the value returned will be true:
    $("#radio2").prop("checked")
    
  • Click on "Choice 1".
  • Type the same snippet as before in the console and the value is now false.
  • Click and hold the click on "Choice 2", then move the cursor from a couple of pixels before releasing it still over the "Choice 2" button.
  • Type the same snippet of code as before and it will return false even though the button "Choice 2" is highlighted.

Change History (1)

comment:1 Changed 3 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9990.

Note: See TracTickets for help on using tickets.