Opened 3 years ago

Closed 3 years ago

#15036 closed bug (duplicate)

jQuery CheckboxRadio Does Not Work With Cloned Dialogs

Reported by: robinwilson16 Owned by:
Priority: minor Milestone: none
Component: ui.checkbxoradio Version: 1.12.0
Keywords: Cc:
Blocked by: Blocking:

Description

Hello

I have just tried out the new jQuery CheckboxRadio controls which work fine on their own and even in a jQueryUI Dialog control.

However when you clone the jQuery Dialog these controls do not work correctly (other jQuery controls do) and I can find no workaround. Basically you cannot check or uncheck them and if checked already then when you hover over the button you see an up arrow rather than a checkmark as you would normally.

I have created a jsFiddle to demonstrate the problem here: https://jsfiddle.net/robinwilson16/0xbrjkwv/

If you uncomment the two lines and comment the 2 below so the dialog is not cloned the code works as it should (switching the one for the dialog and the checkboxes).

Also if you switch only the checkbox lines then you end up with two checkboxes appearing for each one and although they appear checked and unchecked they are not actually updating the underlying checkbox correctly.

Change History (1)

comment:1 Changed 3 years ago by Alexander Schmitz

Resolution: duplicate
Status: newclosed

this actually does not work correctly with out cloneing see https://jsfiddle.net/0xbrjkwv/8/ you still need to hover for them to work this has already been fixed on master and duplicates #15003. The other issues you have here are all because your cloning elements with Id's and not changing the id so you end up with 2 of each control with the same ID which is invalid markup.

Im going to close this issue as a duplicate of #15003 / invalid markup

Note: See TracTickets for help on using tickets.