Opened 13 months ago

Closed 13 months ago

Last modified 6 months ago

#15055 closed bug (fixed)

checkbox radio inside dialog does not work

Reported by: Backslider23 Owned by: Alexander Schmitz
Priority: minor Milestone: 1.12.2
Component: ui.checkbxoradio Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am using a jquery-ui checkbox within a dialog. This is causing the ".ui-widget-content .ui-state-hover" css rule that defines the background property to override the .ui-icon-check rule that defines the correct background-position for the checkbox image. I believe this is because it is more specific.

The result is that a checkbox within a widget-content shows the wrong image.

Check it here: https://jsfiddle.net/4gj76rsL/3/

Change History (4)

comment:1 Changed 13 months ago by Alexander Schmitz

Owner: set to Alexander Schmitz
Status: newassigned

Whats interesting is this only seems to be when the checkbox is initially checked in the markup the first one thats not seems to work fine.

comment:2 Changed 13 months ago by Alexander Schmitz

Resolution: fixed
Status: assignedclosed

In b9d687d:

Checkboxradio: Don't add ui-state-hover to icons

Fixes #15055
Closes gh-1756

comment:3 Changed 13 months ago by Scott González

Component: ui.coreui.checkbxoradio
Milestone: none1.12.2

comment:4 Changed 6 months ago by Scott González

#15164 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.