Opened 2 years ago

Closed 2 years ago

#15164 closed bug (duplicate)

controlgroup bug in dialog

Reported by: AlgirdasR Owned by:
Priority: blocker Milestone: 1.12.2
Component: ui.controlgroup Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description

When controlgroup is in a dialog, it is given an incorrect background-position css property because of .ui-widget-content class. In result an icon is shown inside a radio button despite it having a '.ui-icon-blank' class. http://imgur.com/a/9CmWV

Here is a simple demo I've made: https://jsfiddle.net/q2xrp2nt/

Steps to reproduce: 1) Click on "ligthness" in both controlgroups.

Change History (2)

comment:1 Changed 2 years ago by Scott González

Milestone: none1.12.2
Priority: minorblocker
Status: newopen

Not just the wrong position, potentially the wrong background image as well. The .ui-widget-content .ui-state-hover defines a background rule, so depending on the theme, everything about the background can change. You can see the background image change as well by using the Vader theme.

comment:2 Changed 2 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #15055.
This has actually been fixed in master already.

Note: See TracTickets for help on using tickets.