Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#15102 closed bug (fixed)

ui.DatePicker Prev Button not working with showing multiple month and showCurrentAtPos not equal to zero

Reported by: Umbrae Owned by: Scott González
Priority: minor Milestone: 1.12.2
Component: ui.datepicker Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description

When showing more than 1 month at a time and setting showCurrentAtPos/showCurrentMonthAtPos to be anything but 0, the prev button does not operate (does nothing). Next button will properly advance, but previous has no affect. In the same case (showing multiple months) with showCurrentAtPos and showCurrentMonthAtPos set to zero the previous button works properly as expected.

<script>
$( "#datepicker" ).datepicker({
numberOfMonths: 3,
showButtonPanel: true,
showCurrentAtPos: 1,
showCurrentMonthAtPos: 1
});
</script>
<div id="datepicker"></div>

Change History (5)

comment:1 Changed 2 years ago by Scott González

#15118 is a duplicate of this ticket.

comment:2 Changed 2 years ago by claudi

Seems as if showCurrentAtPos is added to offset when refreshing the datepicker, which is not correct. I've already fixed this for me. How can i contribute?

comment:3 Changed 2 years ago by Scott González

You'll need to file a pull request on GitHub. You can start by reading https://github.com/jquery/jquery-ui/blob/master/CONTRIBUTING.md and http://contribute.jquery.org/commits-and-pull-requests/

If you have any questions, feel free to ask here or IRC.

comment:4 Changed 2 years ago by Scott González

Owner: set to Scott González
Resolution: fixed
Status: newclosed

In 17404ce:

Datepicker: Fix prev/next button behavior with showCurrentAtPos

Fixes #15102
Closes gh-1784

comment:5 Changed 2 years ago by Ryan J Ollos

Milestone: none1.12.2
Note: See TracTickets for help on using tickets.