Opened 11 years ago

Closed 11 years ago

#2859 closed bug (worksforme)

Datepicker 3.4.3 'change' commits changes to all datepickers

Reported by: mnichols Owned by: grabanski
Priority: critical Milestone:
Component: ui.datepicker Version: 1.5b4
Keywords: datepicker 3.4.3 change Cc:
Blocked by: Blocking:

Description

When trying to use the 'change' function, the new settings are applied to all datepickers on page. For example, with the code below, one would expect that only the input 'myrange' would be a ranged datepicker, but in fact it causes all pickers to become range-aware. If this is by design it should be made clearer.

To test: <input type="text" class="date" id="plainoledate"/> <script type="text/javascript"> $(document).ready(function(){ $('.date').datepicker(); }); </script> <input type="text" class="date" id="myrange"/> <script type="text/javascript"> $(document).ready(function(){ $('#myrange').datepicker('change',{ rangeSelect: true}); }); </script>

Change History (4)

comment:1 Changed 11 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:2 Changed 11 years ago by paul

Component: ui.coreui.datepicker
Owner: paul deleted
Version: 1.2.31.5b4

comment:3 Changed 11 years ago by paul

Owner: set to grabanski
Status: newassigned

comment:4 Changed 11 years ago by Scott González

Resolution: worksforme
Status: assignedclosed

I tested your sample code, as well as a few other settings, against latest SVN and couldn't reproduce this problem. If you continue to experience this problem after upgrading to latest SVN, feel free to re-open this ticket.

Note: See TracTickets for help on using tickets.