Opened 12 years ago

Closed 11 years ago

Last modified 7 years ago

#2958 closed bug (notabug)

Tabs wrapping

Reported by: alex.kalinovsky@… Owned by: klaus.hartl
Priority: minor Milestone:
Component: ui.tabs Version: 1.5
Keywords: tabs wrapping Cc:
Blocked by: Blocking:

Description

When there are more tabs then can fit on one line, the tabs start wrapping to multiple lines, which is good. The problem is that the first tab on the second line is horizontally aligned with the currently selected tab on the first line. So instead of the first tab of the second line starting at the left side of <ul>, it starts somewhere in the middle under the currently selected tab. And every time you select a different tab on the first line, all tabs are reordered. You can reproduce the problem by going to your demo page and clicking Add New Tab button 12 times.

http://ui.jquery.com/functional_demos/#ui.tabs

The interesting things is that the demo of jQuery tabs on their home page doesn't have that bug:

http://stilbuero.de/jquery/tabs_3/

This makes jQuery tabs unusable in our environment because we have many tabs.

Change History (5)

comment:1 Changed 12 years ago by paul

Priority: majorminor

Since it's not really a bug, I changed it it 'minor'.

comment:2 Changed 11 years ago by paul

Milestone: 1.5
Version: 1.5

comment:3 Changed 11 years ago by Cloudream

Milestone: TDB
Status: newassigned

a css issue

comment:4 Changed 11 years ago by klaus.hartl

Resolution: invalid
Status: assignedclosed

This no longer applies with #3922 being done.

comment:5 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.