Opened 10 years ago

Closed 8 years ago

Last modified 5 years ago

#3922 closed feature (wontfix)

Tabs: Horizontal scrolling

Reported by: klaus.hartl Owned by: klaus.hartl
Priority: trivial Milestone: 1.8
Component: ui.tabs Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

If number of tabs exceed the available space, buttons should be provided to scroll through the tabs. The tabs shouldn't wrap.

See Firefox for example.

Design is required as well.

Change History (14)

comment:1 Changed 10 years ago by klaus.hartl

Another example: http://cakephp.org/

comment:2 Changed 10 years ago by klaus.hartl

Summary: Provide horizontally scrolling through tabs in case of to less spaceProvide horizontally scrolling through tabs in case of too less space

comment:3 Changed 10 years ago by yanndinendal

I strongly agree with this. There should be a way to do this! I tried with jCarousel (http://sorgalla.com/projects/jcarousel/), but it doesn't work well with tabs: it is made to scroll with items having a fixed width, like images' thumbnails. So it is quite buggy with the variable-length text we have in tabs headers.

comment:4 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.next

comment:5 Changed 10 years ago by Jörn Zaefferer

Milestone: 1.next1.8
Version: 1.6rc51.7.2

Duplicate of #4628

comment:6 Changed 10 years ago by sneed424

comment:7 in reply to:  6 Changed 9 years ago by Rob Loach

Replying to sneed424:

another good example for a previous version of jquery http://code.google.com/p/jquery-ui-tabs-paging/

Example: http://www.seyfertdesign.com/jquery/examples.html

This is REALLY nice.

comment:8 in reply to:  1 Changed 9 years ago by aamirafridi

I just finish working on http://jquery.aamirafridi.com/jst/

Replying to klaus.hartl:

Another example: http://cakephp.org/

comment:9 Changed 9 years ago by aamirafridi

For now I have created a plugin for this:

http://jquery.aamirafridi.com/jst/

comment:11 in reply to:  9 Changed 8 years ago by Corey Frang

Status: newopen

Replying to aamirafridi:

For now I have created a plugin for this:

http://jquery.aamirafridi.com/jst/

I like the result of this work - Perhaps there is a way we could get some of these features baked into the real tabs API?

comment:12 Changed 8 years ago by Scott González

Milestone: 1.91.next
Priority: majortrivial
Summary: Provide horizontally scrolling through tabs in case of too less spaceTabs: Horizontal scrolling

comment:13 Changed 8 years ago by Scott González

Resolution: wontfix
Status: openclosed

This should be built as an extension. It's bad UX to have so many tabs that you need to scroll.

comment:14 Changed 7 years ago by Scott González

Milestone: 1.next1.8

comment:15 Changed 5 years ago by john.allred

Currently when the tabs are wider than the viewport (either because there are too many tabs, or the viewport is too small, or the user has made their browser window smaller) the jquery ui tabs wrap in a very unprofessional manner. While researching this issue I have come across many requests that the ui tabs be made scrollable (which also seems to me to be the logical thing to do), but since you don't want to do that can you at least fix the CSS so when the tabs wrap to multiple lines they don't look like the site was built by a 5th grader?

Note: See TracTickets for help on using tickets.