Opened 11 years ago

Closed 5 years ago

#3629 closed feature (duplicate)

Supporting of Jalali Calendar (Hijiri Date)

Reported by: jmowla Owned by: kbwood
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.5.2
Keywords: Jalali Hijiri Cc:
Blocked by: Blocking:

Description

It sounds good to support Jalali Calendar by Datepicker. I just added this feature and tested the code, but don't know how i can package and post that. is it enought too attach scripts?

Attachments (2)

jalaliCalendar.js (6.2 KB) - added by jmowla 11 years ago.
source of the jalali-calendar feature
datepicker.gif (52.8 KB) - added by jmowla 11 years ago.
demonstration of jalali calendar on datepicker component

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by shivisi

What about the Jewish lunar calendar? Is there a mechanism planned for supporting alternate calendars?

comment:2 Changed 11 years ago by kbwood

Owner: set to kbwood
Status: newassigned

Yes, please attach the code here and provide an explanation of the differences in your calendars.

Changed 11 years ago by jmowla

Attachment: jalaliCalendar.js added

source of the jalali-calendar feature

Changed 11 years ago by jmowla

Attachment: datepicker.gif added

demonstration of jalali calendar on datepicker component

comment:3 Changed 11 years ago by jmowla

so sorry for late respond. using of jalali-calendar feature in datepicker is very simple and i attached a picture about that. Jalali calendar starts at the first day of Spring (in Gregorian calendar some year in 20th of March and sometimes in 21st of March, because of leap year differences in two calendar). it has 31 days in months in first 6 months of year (FARVARDIN,ORDIBEHESH,KHORDAD,TIR,MORDAD,SHAHRIVAR) next 5 months has 30 days in month (MEHR, ABAN, AZAR, DEY, BAHMAN) the last month of the year contains 29 days in normal year and 30 days in leap (KABISAH) year the start of the year does not fix on a certain time, the point that the year will change called (TAHVIL-E SAL)

in the current attached .JS file i couldn't document it good :( but in the future i will spend time to document that. i will be so happy to resolve further bugs that may you occure during usage :">

comment:4 Changed 11 years ago by jmowla

as shivisi told, i think it's a good idea that datepicker have a method like "setCalendar()" and everyone who wants to implements a new calendar, implements an specific interface (object) and register by that method!

comment:5 Changed 11 years ago by kbwood

Resolution: wontfix
Status: assignedclosed

This would require a major rewrite of datepicker to separate it from the JavaScript Date class and to pass all dates as arrays of year/month/day.

comment:6 Changed 11 years ago by jmowla

kbwood, any help can i do? or any changes will you plan in datepicker architecture to support alternative calendars? its a very good datepicker and it will be more powerfull if another calendars can plug into it. we have many calendars in the world :(

comment:7 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

comment:8 Changed 5 years ago by Scott González

Milestone: none
Resolution: wontfix
Status: closedreopened

comment:9 Changed 5 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

Duplicate of #5789.

Note: See TracTickets for help on using tickets.