Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#4028 closed bug (duplicate)

Maximum slider not dragable if set to minimum

Reported by: webdawson Owned by:
Priority: critical Milestone: 1.7
Component: ui.slider Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

Please head over to the Range Slider Example: http://ui.jquery.com/demos/slider/#range

and drag the right maximum slider to the left as far as you can (in this example it will stop at $75). now try to drag the maximum slider again to the right..to an higher value...its not possible, i only can drag the left slider. Thats a big problem if i drag the left slider to 0 and also the right maximum one to 0, than i cant drag any of both sliders.

Change History (5)

comment:1 Changed 11 years ago by webdawson

Oh! Sorry! I see if i drag both to 0 i can drag the maximum to a higher value now (you fixed that in 1.6rc6!)

comment:2 Changed 11 years ago by tmiddel

This still does not work if the slider was configured with a minValue other than 0. Maybe it should be considered to compare to minValue instead to 0. e.g.

if(o.range && (this.values(0) + this.values(1)) == this._valueMin()) {

closestHandle = $(this.handles[++index]);

}

comment:3 Changed 11 years ago by zapek

The following works for me:

if(o.range && (this.values(0) == this.values(1))) {

if (this.values(0) == this._valueMin()) {

index = 1;

} else {

index = 0;

} closestHandle = $(this.handles[index]);

}

The previous change suggested by 'tmiddel' didn't. I tested with a slider going from 18 to 40.

comment:4 Changed 11 years ago by paul

Priority: minorcritical

comment:5 Changed 11 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #3736.

Note: See TracTickets for help on using tickets.