Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4049 closed bug (duplicate)

Opening Dialog causes js error in IE7 if dialog content contains VML

Reported by: robmonie Owned by:
Priority: minor Milestone:
Component: ui.dialog Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

This is a hard one to know where to log so I understand if you think it shouldn't be with jquery-ui although it is caught in the middle between the two libraries that I think aren't playing nicely - dd_roundies.js and jquery 1.3.x. It actually seems to be a regression from when jquery-1.3 was introduced and I believe i've narrowed it down to a particular line in jquery that is failing.

The test I have attached shows that when dd_roundies.js creates VML based rounded corners for any elements within a dialog, jquery throws an error when opening the dialog. I think this is based on the following function in jquery when 'elem' is a VML element.

Sizzle.selectors.filters.visible = function(elem){

return "hidden" !== elem.type &&

jQuery.css(elem, "display") !== "none" && jQuery.css(elem, "visibility") !== "hidden";

};

My VM running IE7 and debugger are playing up at the moment so i'm finding it hard to debug properly.

Attachments (1)

jquery-ui-dialog-with-dd-roundies.zip (99.1 KB) - added by robmonie 10 years ago.
Test Case

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by robmonie

Test Case

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4020.

comment:2 Changed 10 years ago by robmonie

Just for reference, this is also raised against jquery core here - http://dev.jquery.com/ticket/3265

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.