Opened 11 years ago

Closed 7 years ago

#4306 closed feature (duplicate)

Datepicker: Expose option to append to something else then body

Reported by: Jörn Zaefferer Owned by:
Priority: major Milestone: 1.11.0
Component: ui.datepicker Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Jörn Zaefferer)

Currently the datepicker is always appended to the body element, hardcoded (except inline datepickers). The code is even scattered across the plugin, so to change it I have to change various places.

A potential name for the option would be "appendTo", accepting a selector/jQuery object, with the default of "body" or document.body.

For a usecase, see http://groups.google.com/group/jquery-ui-dev/browse_thread/thread/49a59aa4dfb6e96e

Change History (10)

comment:1 Changed 11 years ago by Jörn Zaefferer

Description: modified (diff)

comment:2 Changed 11 years ago by coeamyd

The same option would apply to the Dialog control.

comment:3 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.next

comment:4 Changed 9 years ago by centi

Hi. Is there any chance that this will be fixed soon? Now there is no way to use this datepicker in a scrollable element.

comment:5 Changed 9 years ago by Scott González

This won't be fixed until datepicker is rewritten, which is currently planned for the 2.0 release, but it's possible that it can land in the 1.9 release.

comment:6 Changed 7 years ago by Scott González

Type: enhancementfeature

comment:7 Changed 7 years ago by Scott González

Milestone: 1.next1.11.0

comment:8 Changed 7 years ago by petersendidit

Status: newopen
Summary: Expose option to append to something else then bodyDatepicker: Expose option to append to something else then body

comment:9 Changed 7 years ago by mikesherov

#4591 is a duplicate of this ticket.

comment:10 Changed 7 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #9013.
Closing as a duplicate of #9013 even though this is much older because the newer ticket addresses the specific implementation we'll use.

Note: See TracTickets for help on using tickets.