Opened 10 years ago

Closed 7 years ago

#4591 closed bug (duplicate)

Datepicker: need support for scoping themes

Reported by: momchilsv Owned by:
Priority: major Milestone: 1.11.0
Component: ui.datepicker Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Using the datepicker with some of the other widgets on the same page leads to conflict when both use different themes.

For example, let we have an accordian menu and a form with datepicker, both in the same page. If we want to set a different theme to the datepicker, the only way is to download a custom theme using the ThemeRoller with a "CSS Scope" option e.g. ".theme_datepicker". But the UI generated datepicker div uses an absolute position, so it can't use the custome ".theme_datepicker" class and that's why we can't set a different theme to the datepicker.

Change History (5)

comment:1 Changed 10 years ago by Jörn Zaefferer

Component: ui.coreui.datepicker
Milestone: TBD1.8

Related to #4306

comment:2 Changed 9 years ago by Scott González

Summary: Using the datepicker with some of the other widgets leads to conflictDatepicker: need support for scoping themes

comment:3 Changed 8 years ago by chs

This bug also affect Dialog Widget which append container and overlay directly to <body>

The solution is to take the way of the autocomplete widget and use an "appendTo" option.

comment:4 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:5 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #4306.

Note: See TracTickets for help on using tickets.