Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#4336 closed bug (duplicate)

jQuery UI Accordion 1.7 Invalid Argument Error in IE 6/7 When Theme Not Included

Reported by: Kirsehn Owned by:
Priority: major Milestone:
Component: ui.accordion Version: 1.7
Keywords: IE "Internet Explorer" accordion error theme Cc:
Blocked by: Blocking:

Description

If I try to use the jQuery UI accordion in a page without using one of the jQuery UI themes (for example 'smoothness'), I get a Javascript "Invalid Argument" error in Internet Explorer Versions 6 and 7 when clicking on any heading item, and the accordion does not function.

Including the theme CSS files appears to fix the problem, but I would think that the Javascript should still work without the theme (since it is an option to download the files without one).

Without using the theme CSS, including...

<style type="text/css">
.ui-helper-reset { border: 0; }
</style> 

...will fix the problem in IE6. However, in IE7 issues still exists in this fashion: As long as you click to collapse the open heading before clicking on the next one, it works correctly (although a bit jerky). If you click on a different heading before collapsing the currently-open one, however, the same "invalid argument" error is thrown and the accordion no longer functions.

The code I am using for my accordion is as follows:

Javascript:

$(document).ready(function(){
        $('#accordion').accordion({ header: 'dt', autoHeight: false,
collapsible: true, active: false });

}); 

HTML:

<div id="accordion">
<dl>
<dt>Click here to open 1</dt>
<dd>Content 1</dd>
</dl>
<dl>
<dt>Click here to open 2</dt>
<dd>Content 2</dd>
</dl>
...etc...
</div> 

Change History (4)

comment:1 Changed 11 years ago by enerdev

set style="border: none 0px;" on your <dd> sections and it will fix it

comment:2 in reply to:  1 Changed 11 years ago by enerdev

Replying to enerdev:

set style="border: none 0px;" on your <dd> sections and it will fix it

I forgot to mention see bug #4352

comment:3 Changed 11 years ago by rdworth

Resolution: duplicate
Status: newclosed

Duplicate of #4331

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.