Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#4348 closed bug (fixed)

datepicker positioned outside body when scrollbar enabled

Reported by: xorax Owned by:
Priority: minor Milestone: 1.8
Component: ui.datepicker Version: 1.7
Keywords: datepicker position Cc:
Blocked by: Blocking:

Description

the detection of windows size is false (including scrollbar). so datepicker is outside content that it should normally be near the border.

Attachments (1)

patch.diff (1.8 KB) - added by xorax 11 years ago.
replace windows size detection order

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by xorax

Attachment: patch.diff added

replace windows size detection order

comment:1 Changed 11 years ago by Scott González

Milestone: TBD1.8

comment:2 Changed 11 years ago by kbwood

Resolution: fixed
Status: newclosed
Summary: datepicker positionned ouside body when scrollbar enabledatepicker positioned outside body when scrollbar enabled

Fixed in r2447. After some further testing, document.documentElement.clientWidth/Height is available in all major browsers and reflects the available window size excluding any scroll bars.

comment:3 Changed 7 years ago by mikesherov

#5585 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.