Opened 10 years ago

Closed 7 years ago

Last modified 6 years ago

#5585 closed bug (duplicate)

Datepicker Position Problem in IE 8

Reported by: iratherscribble Owned by:
Priority: major Milestone: 1.11.0
Component: ui.datepicker Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

With an input at the bottom-left of the viewport and you click on it, the datepicker opens below, outside of the view. Scrollbar appears, but when you go to scroll, the datepicker is dismissed and the scrollbar disappears. In this case, there is no way to use the datepicker. Change script references to 1.7.2 and datepicker appears above the input and works as expected. This was a problem previously in ticket 3232. Regression in 1.8.

Attachments (2)

jqueryui18_datepicker.png (44.1 KB) - added by iratherscribble 10 years ago.
datepicker behavior in 1.8
jqueryui172_datepicker.png (71.0 KB) - added by iratherscribble 10 years ago.
datepicker behavior in 1.7.2

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by iratherscribble

Attachment: jqueryui18_datepicker.png added

datepicker behavior in 1.8

Changed 10 years ago by iratherscribble

Attachment: jqueryui172_datepicker.png added

datepicker behavior in 1.7.2

comment:1 Changed 9 years ago by giannaccio

i had the same problem.

I fixed it like in the patch for ticket 3232.

So at line 8387 change your code with

//2010/06/23 fix position in ie8
//old
//var viewWidth = document.documentElement.clientWidth + $(document).scrollLeft();
//var viewHeight = document.documentElement.clientHeight + $(document).scrollTop();
//
var browserWidth = (window.innerWidth || (document.documentElement && document.documentElement.clientWidth) || document.body.clientWidth); 
var browserHeight = (window.innerHeight || (document.documentElement && document.documentElement.clientHeight) || document.body.clientHeight); 
var viewWidth = browserWidth + $(document).scrollLeft();
var viewHeight = browserHeight + $(document).scrollTop();

//end fix
Last edited 7 years ago by mikesherov (previous) (diff)

comment:2 Changed 9 years ago by Scott González

Datepicker should use the position plugin.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:4 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #4348.

comment:5 Changed 6 years ago by randjc

@mikesherov - This needs to be re-opened, as this is still an issue with IE8 on version 1.10.3

Last edited 6 years ago by Scott González (previous) (diff)

comment:6 in reply to:  5 Changed 6 years ago by Scott González

Replying to randjc:

@mikesherov - This needs to be re-opened, as this is still an issue with IE8 on version 1.10.3

The milestone for this ticket is 1.11.0, which means that it *should* still be broken in 1.10.3. If you are still having problems with the master branch, let us know.

Note: See TracTickets for help on using tickets.