Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#4497 closed bug (duplicate)

Content below Accordion moves/jumps!

Reported by: sonu27 Owned by:
Priority: critical Milestone: 1.8
Component: ui.accordion Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

This was introduced in 1.6rc6 as the animation was changed slightly. In 1.6rc5 this did not happen.

This makes all the content below the accordion jump. Which is not very nice to see.

To reproduce: http://jquery-ui.googlecode.com/svn/trunk/demos/accordion/default.html

Click the different sections, in random order. You will see the content below the Accordion move/jump. You every noticeable especially when there is a lot of content below the Accordion.

In the default functionality of the Accordion, this should NOT happen.

Please fix immediately.

Tested in latest Firefox, Chrome and IE.

Change History (4)

comment:1 Changed 11 years ago by Jörn Zaefferer

This is probably the oldest accordion issue, and also the biggest reason for the plugin to exist at all. Without those issues, it would be trivial to write one from scratch. Of course Themeroller is a good argument, too.

If you use the default autoHeight:true accordion, you can manually set a fixed height for the entire accordion. That way it doesn't resize during the animation. But thats not an acceptable solution to implement in the plugin.

comment:2 Changed 11 years ago by sonu27

Perhaps, I didn't make myself clear.

The default functionality of the Accordion is autoHeight:True. When you set the autoHeight to False, then the content below will move with the accordion. This is the what is supposed to happen.

However, on autoHeight:True the content below the Accordion jumps ever so slightly. The text moves up and down about a pixel each. Look closely and compare it to 1.6rc5 where nothing jumps.

To reproduce: http://jquery-ui.googlecode.com/svn/trunk/demos/accordion/default.html

Still NOT fixed!

comment:3 Changed 11 years ago by chenyi

This might be another issue. If you look at this page http://jquery-ui.googlecode.com/svn/trunk/demos/accordion/default.html in IE7 and IE6, you will notice the accordion headers below animation section will move up and down slightly. This specific issue doesn't happen in Firefox.

It looks like the new implementation in 1.7.2 for animations.slide is the issue. I replaced the implementation for animations.slide in 1.7.2 with the implementation from 1.6 and kept everything else the same for 1.7.2. The issue I described above in IE7 and IE6 went away.

comment:4 Changed 11 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4149.

Note: See TracTickets for help on using tickets.