Opened 11 years ago

Closed 9 years ago

Last modified 7 years ago

#4533 closed feature (duplicate)

Add support for custom calendars

Reported by: mahdi Owned by:
Priority: major Milestone: 1.7.2
Component: ui.datepicker Version: 1.7.1
Keywords: cusom calendar Cc:
Blocked by: Blocking:

Description

This datepicker has good support for localization, but for some, this ain't enough. I need the support for custom calendar too. I need to use this datepicker with Jalali Canlendar (instead of the default Georgian Calendar).

In my own case, I built a new class called JalaliDate with the same methods as Date class (the default javascript Date class) such as setDate, setFullYear, getDate, getMonth, etc. then in the code, I replaced all "Date()" references with "JalaliDate()" and it worked just perfect in my case.

I think it's a good idea to add the support for this type of custom Date classes. so that when localizing the calendar, one would be able to set the "Date" inteface too.

PS: if you think it's needed, I can provide you with my JalaliDate class which I talked about.

Change History (6)

comment:1 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.next

Will be possible with Marc's calendar engine.

comment:2 Changed 10 years ago by mahdi

unfortunately I'm not familiar with this "Marc's calendar engine" and I couldn't find anything about it either. could you please tell me more?

comment:3 Changed 10 years ago by kbwood

Also see http://keith-wood.name/calendars.html for an implementation of several of the world's calendars.

comment:4 Changed 10 years ago by mahdi

Actually I've implemented what I needed! Here's the Jalali and Islamic(Hijri) DatePicker: http://hasheminezhad.com/sites/default/files/hasheminezhad.com/datepicker-cc7.zip

comment:5 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5789.

comment:6 Changed 7 years ago by Scott González

Milestone: 1.next1.7.2
Note: See TracTickets for help on using tickets.